请选择 进入手机版 | 继续访问电脑版

中国学客联盟

 找回密码
 立即注册
查看: 1227|回复: 10

[思科配置实例] cisco路由器OSPF Stub和Totally Stub的配置

[复制链接]

中级会员

Rank: 3Rank: 3Rank: 3

UID
72
威望
58
贡献
0
在线时间
1 小时
注册时间
2014-2-26
发表于 2016-4-4 18:50:37 | 显示全部楼层 |阅读模式
OSPF Stub和Totally Stub的配置
一、 实验目的
1. 掌握 OSPF 末梢区域和完全末梢区域的配置
2. 理解 OSPF 末梢区域和完全末梢区域的意义
二、 应用环境
在大规模网络中,我们通常划分区域减少资源消耗,并将拓扑的变化本地化。有些区域只有 一个 ABR,而且与骨干区域相连,在这样的区域我们可以定义为末梢区域,进一步减少路 由表的长度
三、 实验设备
1. DCR-1751 三台
2. CR-V35MT 一条
3. CR-V35FC 一条
四、 实验拓扑

五、 实验要求
配置表
Router-A
Router-B
Router-C
S1/1(DCE)
192.168.1.1
S/1/0(DTE)
192.168.1.2
F0/0
192.168.2.2
F0/0
192.168.0.1
F0/0
192.168.2.1
E1/0
192.168.3.1
路由器 B 为 ABR,Area1 为末梢区域
六、 实验步骤
第一步:参照实验三和上表配置各接口地址,并测试连通性
第二步:路由器A 的配置
Router-A#conf
Router-A_config#router ospf 100
Router-A_config_ospf_100#network 192.168.0.0 255.255.255.0 area 1
Router-A_config_ospf_100#network 192.168.1.0 255.255.255.0 area 1
Router-A_config_ospf_100#^Z
第三步:路由器B 的配置
Router-B#conf
Router-B_config#router ospf 100
Router-B_config_ospf_100#network 192.168.1.0 255.255.255.0 area 1
!注意区域的划分在接口上
Router-B_config_ospf_100#network 192.168.2.0 255.255.255.0 area 0
Router-B_config_ospf_100#^Z
第四步:路由器C 的配置
Router-C#conf
Router-C_config#router ospf 100
Router-C_config_ospf_100#network 192.168.2.0 255.255.255.0 area 0
Router-C_config_ospf_100#network 192.168.3.0 255.255.255.0 area 0
Router-C_config_ospf_100#^Z
第五步:查看路由表
Router-A#sh ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type
VRF ID: 0
C
192.168.0.0/24
is directly connected, FastEthernet0/0
C
192.168.1.0/24
is directly connected, Serial1/1
O IA
192.168.2.0/24
[110,1601] via 192.168.1.2(on Serial1/1)
O IA
192.168.3.0/24
[110,1611] via 192.168.1.2(on Serial1/1)
!区域间的路由
第六步:将Area1 定义为完全末梢区域
Router-A#conf
Router-A_config#router ospf 100
Router-A_config_ospf_100#area 1 stub !区域内的所有路由器都要配置成末梢区域
Router-B_config#router ospf 100
Router-B_config_ospf_100#area 1 stub no-summary !ABR 上配置指明完全末梢区域
第七步:再次查看路由器A 的路由表
Router-A#sh ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type
VRF ID: 0
O IA
0.0.0.0/0
[110,1700] via 192.168.1.2(on Serial1/1)
!产生缺省路由
C
192.168.0.0/24
is directly connected, FastEthernet0/0
C
192.168.1.0/24
is directly connected, Serial1/1
Router-A#exit
七、 注意事项和排错
1. 末梢区域的所有路由器都要配置
2. ABR 配置为完全末梢区域
3. 末梢区域里不能有 ASBR 存在
八、 配置序列
Router-B#sh run
正在收集配置...
当前配置:
!
!version 1.3.2E
service timestamps log date
service timestamps debug date
no service password-encryption
!
hostname Router-B
!
ip host a 192.168.1.1
ip host c 192.168.2.2
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
!
interface Async0/0
no ip address
no ip directed-broadcast
!
!
!
router ospf 100
network 192.168.1.0 255.255.255.0 area 1
network 192.168.2.0 255.255.255.0 area 0
area 1 stub no-summary
!
!
!
九、 共同思考
1. 末梢区域的作用是什么?
2. 缺省路由是如何产生的?
中国学客联盟

高级会员

Rank: 4

UID
476
威望
137
贡献
0
在线时间
1 小时
注册时间
2014-2-26
发表于 2016-9-6 20:32:51 | 显示全部楼层
说的非常好
中国学客联盟

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640391
威望
68
贡献
0
在线时间
0 小时
注册时间
2016-9-5
发表于 2016-9-6 20:44:11 | 显示全部楼层
顶顶多好
中国学客联盟

高级会员

Rank: 4

UID
3553480
威望
155
贡献
0
在线时间
1 小时
注册时间
2014-6-16
发表于 2016-9-6 21:05:09 | 显示全部楼层
内容非常不错,谢谢楼主,我学到了

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640395
威望
63
贡献
0
在线时间
0 小时
注册时间
2016-9-6
发表于 2016-9-6 21:05:26 | 显示全部楼层
真心顶
中国学客联盟

高级会员

Rank: 4

UID
3553480
威望
155
贡献
0
在线时间
1 小时
注册时间
2014-6-16
发表于 2016-9-6 21:24:28 | 显示全部楼层
楼主是超人

金牌会员

Rank: 6Rank: 6Rank: 6

UID
5
威望
380
贡献
0
在线时间
3 小时
注册时间
2014-2-26
发表于 2016-11-21 10:19:31 | 显示全部楼层
中国学客联盟好厉害啊
中国学客联盟

金牌会员

Rank: 6Rank: 6Rank: 6

UID
4
威望
354
贡献
0
在线时间
3 小时
注册时间
2014-2-26
发表于 2016-11-21 10:22:16 | 显示全部楼层
楼主是超人
中国学客联盟
 成长值: 1234

副站长

Rank: 78Rank: 78Rank: 78Rank: 78Rank: 78Rank: 78Rank: 78Rank: 78Rank: 78

UID
11
威望
10374
贡献
10999
在线时间
10 小时
注册时间
2014-2-26

2015年度盛典活动奖励勋章巨蟹座勋章摩羯座勋章射手座勋章狮子座勋章靓号

发表于 2016-11-21 10:25:44 | 显示全部楼层
很不错
中国学客联盟

金牌会员

Rank: 6Rank: 6Rank: 6

UID
4
威望
354
贡献
0
在线时间
3 小时
注册时间
2014-2-26
发表于 2016-11-21 10:43:27 | 显示全部楼层
好东西
中国学客联盟
高级模式
B Color Image Link Quote Code Smilies

本版积分规则

关闭

官方推荐上一条 /3 下一条

快速回复 返回顶部 返回列表