中国学客联盟

 找回密码
 立即注册
查看: 719|回复: 7

[思科配置实例] cisco路由器扩展访问列表的配置

[复制链接]

新手上路

Rank: 1

UID
87
威望
0
贡献
0
在线时间
1 小时
注册时间
2014-2-26
发表于 2016-4-2 10:34:50 | 显示全部楼层 |阅读模式
扩展访问列表的配置
一、 实验目的
1. 掌握扩展访问列表的配置
2. 理解理解扩展访问列表丰富的过滤条件
二、 应用环境
1. 可以针对目标 IP 地址进行控制
2. 针对某些服务进行控制
3. 可以针对某些协议进行控制
三、 实验设备
1.
DCR-1751
两台
2.
PC 机
两台
3.
CR-V35MT
一条
4.
CR-V35FC
一条
5.
网线
两条
四、 实验拓扑
QQ截图20160402103642.png
五、 实验要求
ROUTER-A
ROUTER-B
S1/1 (DCE)
192.168.1.1/24
S1/0 (DTE)
192.168.1.2/24
F0/0
192.168.0.1/24
F0/0
192.168.2.1/24
PC-A
PC-B
IP
192.168.0.2/24
192.168.2.2/24
网关
192.168.0.1
192.168.2.1
实验目标:禁止 192.168.0.0/24 Telnet 到 PC-B,但能 Ping。
六、 实验步骤
第一步:参照实验三和上表,配置所有接口的地址,并测试连通性
Router-A#ping 192.168.1.2
PING 192.168.1.2 (192.168.1.2): 56 data bytes
!!!!!
--- 192.168.1.2 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 20/28/30 ms
第二步:参照实验七,配置静态路由
Router-A#sh ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type
VRF ID: 0
C
192.168.0.0/24
is directly connected, FastEthernet0/0
C
192.168.1.0/24
is directly connected, Serial1/1
S
192.168.2.0/24
[1,0] via 192.168.1.2
Router-B#sh ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type
VRF ID: 0
S
192.168.0.0/24
[1,0] via 192.168.1.1
C
192.168.1.0/24
is directly connected, Serial1/0
C
192.168.2.0/24
is directly connected, FastEthernet0/0
第三步:PC-A 能与 PC-B 通讯

第四步:在ROUTER-A 上设置访问列表
Router-A#conf
Router-A_config#ip access-list extended 192 !定义扩展访问列表
Router-A_config_ext_nacl#deny tcp 192.168.0.0 255.255.255.0 192.168.2.2 255.255.255.255 eq 23
!设置扩展访问列表,拒绝Telnet
Router-A_config_ext_nacl#permit icmp any any !允许Ping
Router-A_config_ext_nacl#exit
Router-A_config#int f0/0 !进入离源比较近的接口
Router-A_config_f0/0#ip access-group 192 in !绑定访问列表在IN 的方向
第五步:查看访问列表
Router-A#sh ip access-list
Extended IP access list 192
deny tcp 192.168.0.0 255.255.255.0 192.168.2.2 255.255.255.0 eq telnet
permit icmp any any
第六步:验证

七、 注意事项和排错
1. 扩展访问列表通常放在离源比较近的地方
2. 扩展访问列表可以基于源、目标 IP、协议、端口号等条件过滤
3. 命令比较长,可以通过?的方式查看帮助
4. 注意隐含的 DENY
八、 配置序列
Router-A#sh run
Building configuration...
Current configuration:
!
!version 1.3.2E
service timestamps log date
service timestamps debug date
no service password-encryption
!
hostname Router-A
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
no ip directed-broadcast
ip access-group 192 in
!
interface Serial1/0
no ip address
no ip directed-broadcast
physical-layer speed 64000
!
interface Serial1/1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
physical-layer speed 64000
!
interface Async0/0
no ip address
no ip directed-broadcast
!
!
!
ip route 192.168.2.0 255.255.255.0 192.168.1.2
!
!
ip access-list extended 192
deny tcp 192.168.0.0 255.255.255.0 192.168.2.2 255.255.255.0 eq telnet
permit icmp any any
!
!
!
九、 共同思考
1. 为什么扩展访问列表通常放在源比较近的接口?
2. 访问列表中主机还有什么表示方法?
3. 为什么访问列表中至少要有一条允许?
中国学客联盟

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640425
威望
67
贡献
0
在线时间
0 小时
注册时间
2016-9-28
发表于 2016-10-9 17:36:48 | 显示全部楼层
好帖就是要顶
中国学客联盟

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640412
威望
67
贡献
0
在线时间
0 小时
注册时间
2016-9-17
发表于 2016-10-9 17:06:55 | 显示全部楼层
说的非常好
中国学客联盟

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640424
威望
62
贡献
0
在线时间
0 小时
注册时间
2016-9-28
发表于 2016-10-9 17:20:47 | 显示全部楼层
LZ真是人才
镜花水月

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640421
威望
62
贡献
0
在线时间
0 小时
注册时间
2016-9-21
发表于 2016-10-9 17:12:13 | 显示全部楼层
内容非常不错,谢谢楼主,我学到了
中国学客联盟

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640417
威望
58
贡献
0
在线时间
2 小时
注册时间
2016-9-18
发表于 2016-10-9 17:40:36 | 显示全部楼层
非常好的内容,路过看看,保存一下
今天你对我爱答不理,明天我让你高攀不起

高级会员

Rank: 4

UID
3638710
威望
0
贡献
0
在线时间
0 小时
注册时间
2015-8-31
发表于 2020-1-1 15:36:16 | 显示全部楼层
沙发位出租,有意请联系电话:13838384381
中国学客联盟

高级会员

Rank: 4

UID
3638491
威望
0
贡献
0
在线时间
0 小时
注册时间
2015-7-11
发表于 2020-1-1 17:01:38 | 显示全部楼层
传说中的沙发???哇卡卡
中国学客联盟
高级模式
B Color Image Link Quote Code Smilies

本版积分规则

快速回复 返回顶部 返回列表