设为首页收藏本站

中国学客联盟

 找回密码
 立即注册




查看: 624|回复: 5

[思科配置实例] cisco思科多层交换机静态路由实验

  [复制链接]

[UID商城]   [抢购靓号]

新手上路

Rank: 1

UID
87
威望
0
贡献
0
在线时间
1 小时
注册时间
2014-2-26
金钱
8
发表于 2016-4-2 10:32:37 | 显示全部楼层 |阅读模式

[td]cisco思科多层交换机静态路由实验
一、 实验目的1、 理解三层交换机进行路由的原理和具体实现拓扑;2、 理解三层交换机静态路由的配置方法;[/td]二、 应用环境
当两台三层交换机级联时,为了保证每台交换机上所连接的网段可以和另一台交换机上 连接的网段互相通信,最简单的方法就是设置静态路由。
三、 实验设备
1、 DCRS-7604(或 6804)交换机 1 台
2、 DCRS-5526S 交换机 1 台
3、 PC 机 2-4 台
4、 Console 线 1-2 根
5、 直通网线 2-4 根
四、 实验拓扑
QQ截图20160402103347.png
五、 实验要求
1、 在交换机 A 和交换机 B 上分别划分基于端口的 VLAN:
交换机
VLAN
端口成员
交换机 A
10
1~8
交换机 A
20
9~16
交换机 A
100
24
交换机 B
30
1~8
交换机 B
40
9~16
交换机 B
40
9~16
2、 交换机 A 和 B 通过的 24 口级联。
3、 配置交换机 A 和 B 各 VLAN 虚拟接口的 IP 地址分别如下表所示:
VLAN10
VLAN20
VLAN30
VLAN40
VLAN100
VLAN101
192.168.10.1
192.168.20.1
192.168.30.1
192.168.40.1
192.168.100.1
192.168.100.2
4、 PC1-PC4 的网络设置为:
设备
IP 地址
gateway
Mask
PC1
192.168.10.101
192.168.10.1
255.255.255.0
PC2
192.168.20.101
192.168.20.1
255.255.255.0
PC3
192.168.30.101
192.168.30.1
255.255.255.0
PC4
192.168.40.101
192.168.40.1
255.255.255.0
5、 验证:
z 没有静态路由之前:
PC1 与 PC2,PC3 与 PC4 可以互通。
PC1、PC2 与 PC3、PC4 不通。
z 配置静态路由之后:
四台 PC 之间都可以互通。
z 若实验结果和理论相符,则本实验完成。
六、 实验步骤
第一步:交换机全部恢复出厂设置,配置交换机的VLAN信息
交换机A:
DCRS-7604#conf
DCRS-7604(Config)#vlan 10
DCRS-7604(Config-Vlan10)#switchport interface ethernet 1/1-8
Set the port Ethernet1/1 access vlan 10 successfully
Set the port Ethernet1/2 access vlan 10 successfully
Set the port Ethernet1/3 access vlan 10 successfully
Set the port Ethernet1/4 access vlan 10 successfully
Set the port Ethernet1/5 access vlan 10 successfully
Set the port Ethernet1/6 access vlan 10 successfully
Set the port Ethernet1/7 access vlan 10 successfully
Set the port Ethernet1/8 access vlan 10 successfully
DCRS-7604(Config-Vlan10)#exit
DCRS-7604(Config)#vlan 20
DCRS-7604(Config-Vlan20)#switchport interface ethernet 1/9-16
Set the port Ethernet1/9 access vlan 20 successfully
Set the port Ethernet1/10 access vlan 20 successfully
Set the port Ethernet1/11 access vlan 20 successfully
Set the port Ethernet1/12 access vlan 20 successfully
Set the port Ethernet1/13 access vlan 20 successfully
Set the port Ethernet1/14 access vlan 20 successfully
Set the port Ethernet1/15 access vlan 20 successfully
Set the port Ethernet1/16 access vlan 20 successfully
DCRS-7604(Config-Vlan20)#exit
DCRS-7604(Config)#vlan 100
DCRS-7604(Config-Vlan100)#switchport interface ethernet 1/24
Set the port Ethernet1/24 access vlan 100 successfully
DCRS-7604(Config-Vlan100)#exit
DCRS-7604(Config)#
验证配置:
DCRS-7604#show vlan
[tr][/tr]
VLANNameTypeMediaPorts
----      ------------       ----------     ---------       -------------------
1defaultStaticENETEthernet0/0/17Ethernet0/0/18
Ethernet0/0/19Ethernet0/0/20
Ethernet0/0/21Ethernet0/0/22
Ethernet0/0/23Ethernet0/0/25
Ethernet0/0/26Ethernet0/0/27
Ethernet0/0/28
10VLAN0010StaticENETEthernet0/0/1Ethernet0/0/2
Ethernet0/0/3Ethernet0/0/4
Ethernet0/0/5Ethernet0/0/6
Ethernet0/0/7Ethernet0/0/8
20VLAN0020StaticENETEthernet0/0/9Ethernet0/0/10
Ethernet0/0/11Ethernet0/0/12
Ethernet0/0/13Ethernet0/0/14
Ethernet0/0/15Ethernet0/0/16
100VLAN0100StaticENETEthernet0/0/24

DCRS-7604#
交换机B:
DCRS-5526S(Config)#vlan 30
DCRS-5526S(Config-Vlan30)#switchport interface ethernet 0/0/1-8
Set the port Ethernet0/0/1 access vlan 30 successfully
Set the port Ethernet0/0/2 access vlan 30 successfully
Set the port Ethernet0/0/3 access vlan 30 successfully
Set the port Ethernet0/0/4 access vlan 30 successfully
Set the port Ethernet0/0/5 access vlan 30 successfully
Set the port Ethernet0/0/6 access vlan 30 successfully
Set the port Ethernet0/0/7 access vlan 30 successfully
Set the port Ethernet0/0/8 access vlan 30 successfully
DCRS-5526S(Config-Vlan30)#exit
DCRS-5526S(Config)#vlan 40
DCRS-5526S(Config-Vlan40)#switchport interface ethernet 0/0/9-16
Set the port Ethernet0/0/9 access vlan 40 successfully
Set the port Ethernet0/0/10 access vlan 40 successfully
Set the port Ethernet0/0/11 access vlan 40 successfully
Set the port Ethernet0/0/12 access vlan 40 successfully
Set the port Ethernet0/0/13 access vlan 40 successfully
Set the port Ethernet0/0/14 access vlan 40 successfully
Set the port Ethernet0/0/15 access vlan 40 successfully
Set the port Ethernet0/0/16 access vlan 40 successfully
DCRS-5526S(Config-Vlan40)#exit
DCRS-5526S(Config)#vlan 101
DCRS-5526S(Config-Vlan101)#switchport interface ethernet 0/0/24
Set the port Ethernet0/0/24 access vlan 101 successfully
DCRS-5526S(Config-Vlan101)#exit
DCRS-5526S(Config)#
验证配置:
DCRS-5526S#show vlan

[tr][/tr]
VLANNameTypeMediaPorts
----      ------------       ----------     ---------       -------------------
1defaultStaticENETEthernet0/0/17Ethernet0/0/18
Ethernet0/0/19Ethernet0/0/20
Ethernet0/0/21Ethernet0/0/22
Ethernet0/0/23
30VLAN0030StaticENETEthernet0/0/1Ethernet0/0/2
Ethernet0/0/3Ethernet0/0/4
Ethernet0/0/5Ethernet0/0/6
Ethernet0/0/7Ethernet0/0/8
40VLAN0040StaticENETEthernet0/0/9Ethernet0/0/10
Ethernet0/0/11Ethernet0/0/12
Ethernet0/0/13Ethernet0/0/14
Ethernet0/0/15Ethernet0/0/16
101VLAN0101StaticENETEthernet0/0/24

DCRS-5526S#
第二步:配置交换机各vlan虚接口的IP地址
交换机A:
DCRS-7604(Config)#int vlan 10
DCRS-7604(Config-If-Vlan10)#ip address 192.168.10.1 255.255.255.0
DCRS-7604(Config-If-Vlan10)#no shut
DCRS-7604(Config-If-Vlan10)#exit
DCRS-7604(Config)#int vlan 20
DCRS-7604(Config-If-Vlan20)#ip address 192.168.20.1 255.255.255.0
DCRS-7604(Config-If-Vlan20)#no shut
DCRS-7604(Config-If-Vlan20)#exit
DCRS-7604(Config)#int vlan 100
DCRS-7604(Config-If-Vlan100)#ip address 192.168.100.1 255.255.255.0
DCRS-7604(Config-If-Vlan100)#no shut
DCRS-7604(Config-If-Vlan100)#
DCRS-7604(Config-If-Vlan100)#exit
DCRS-7604(Config)#
交换机B:
DCRS-5526S(Config)#int vlan 30
DCRS-5526S(Config-If-Vlan30)#ip address 192.168.30.1 255.255.255.0
DCRS-5526S(Config-If-Vlan30)#no shut
DCRS-5526S(Config-If-Vlan30)#exit
DCRS-5526S(Config)#interface vlan 40
DCRS-5526S(Config-If-Vlan40)#ip address 192.168.40.1 255.255.255.0
DCRS-5526S(Config-If-Vlan40)#exit
DCRS-5526S(Config)#int vlan 101
DCRS-5526S(Config-If-Vlan101)#ip address 192.168.100.2 255.255.255.0
DCRS-5526S(Config-If-Vlan101)#exit
DCRS-5526S(Config)#
第三步:配置各PC的IP地址,注意配置网关
设备
IP 地址
gateway
Mask
PC1
192.168.10.101
192.168.10.1
255.255.255.0
PC2
192.168.20.101
192.168.20.1
255.255.255.0
PC3
192.168.30.101
192.168.30.1
255.255.255.0
PC4
192.168.40.101
192.168.40.1
255.255.255.0
第四步:验证PC之间是否连通?
PC
端口
PC
端口
结果
原因
PC1
A:1/1
PC2
A:1/9

PC1
A:1/1
Vlan 100
A:1/24

PC1
A:1/1
Vlan 101
B:0/0/24
不通
PC1
A:1/1
PC3
B:0/0/1
不通
查看路由表,进一步分析上一步的现象原因。
交换机A:
DCRS-7604#show ip route
Total route items is 3, the matched route items is 3
Codes: C - connected, S - static, R - RIP derived, O - OSPF derived
A - OSPF ASE, B - BGP derived, D - DVMRP derived
Destination
Mask
Nexthop
Interface
Preference
C
192.168.10.0
255.255.255.0
0.0.0.0
Vlan10
0
C
192.168.20.0
255.255.255.0
0.0.0.0
Vlan20
0
C
192.168.100.0
255.255.255.0
0.0.0.0
Vlan100
0
DCRS-7604#
(C代表直连的网段)
交换机B:
DCRS-5526S#show ip route
Total route items is 3, the matched route items is 3
Codes: C - connected, S - static, R - RIP derived, O - OSPF derived
A - OSPF ASE, B - BGP derived, D - DVMRP derived
Destination
Mask
Nexthop
Interface
Preference
C
192.168.10.0
255.255.255.0
0.0.0.0
Vlan30
0
C
192.168.20.0
255.255.255.0
0.0.0.0
Vlan40
0
C
192.168.100.0
255.255.255.0
0.0.0.0
Vlan101
0
DCRS-5526S#
第五步:配置静态路由
交换机A:
DCRS-7604(Config)#ip route 192.168.30.0 255.255.255.0 192.168.100.2
DCRS-7604(Config)#ip route 192.168.40.0 255.255.255.0 192.168.100.2
验证配置:
DCRS-7604#show ip route
Total route items is 5, the matched route items is 5
Codes: C - connected, S - static, R - RIP derived, O - OSPF derived
A - OSPF ASE, B - BGP derived, D - DVMRP derived
Destination
Mask
Nexthop
Interface
Preference
C
192.168.10.0
255.255.255.0
0.0.0.0
Vlan10
0
C
192.168.20.0
255.255.255.0
0.0.0.0
Vlan20
0
S
192.168.30.0
255.255.255.0
192.168.100.2
Vlan100
1
S
192.168.40.0
255.255.255.0
192.168.100.2
Vlan100
1
C
192.168.100.0
255.255.255.0
0.0.0.0
Vlan100
0

DCRS-7604#
(S代表静态配置的网段)
交换机B:
DCRS-5526S(Config)#ip route 192.168.10.0 255.255.255.0 192.168.100.1
DCRS-5526S(Config)#ip route 192.168.20.0 255.255.255.0 192.168.100.1
验证配置:
DCRS-5526S#show ip route
Total route items is 5, the matched route items is 5
Codes: C - connected, S - static, R - RIP derived, O - OSPF derived
A - OSPF ASE, B - BGP derived, D - DVMRP derived
Destination
Mask
Nexthop
Interface
Preference
S
192.168.10.0
255.255.255.0
192.168.100.1
Vlan101
1
S
192.168.20.0
255.255.255.0
192.168.100.1
Vlan101
1
C
192.168.30.0
255.255.255.0
0.0.0.0
Vlan30
0
C
192.168.40.0
255.255.255.0
0.0.0.0
Vlan40
0
C
192.168.100.0
255.255.255.0
0.0.0.0
Vlan101
0
DCRS-5526S#
第六步:验证PC之间是否连通?
PC
端口
PC
端口
结果
原因
PC1
A:1/1
PC2
A:1/9

PC1
A:1/1
Vlan 100
A:1/24

PC1
A:1/1
Vlan 101
B:0/0/24

PC1
A:1/1
PC3
B:0/0/1

七、 注意事项和排错
1、 PC 机一定要配置正确的网关,否则不能正常通信;
2、 两台交换机级联的端口可以在同一 vlan,也可以在不同 vlan。
八、
1、 如果把交换机 B 上的 vlan30 改成 vlan10,请问两台交换机上的 vlan10 是同一个
VLAN 么?
2、 第四步中,PC1 ping vlan101 以及 PC1 ping PC3 都不通,其原因各是什么?
十、 相关配置命令详解
ip route命令:ip route <ip_address> <mask> <gateway> [<preference>]
no ip route <ip_address> <mask> <gateway> [<preference>]
功能:配置静态路由;本命令的no 操作为删除静态路由。
参数:<ip_address>和<mask>分别为目的IP 地址和子网掩码,点分十进制格式; <gateway>
为下一跳的IP 地址,点分十进制格式;<preference>为路由优先级,取值范围为1~255,
preference 的值越小优先级越高。
缺省情况:DCRS-7604 三层交换机的静态路由缺省优先级为1。
命令模式:全局配置模式
使用指南:在配置静态路由的下一跳时,可采用指定路由数据包发送下一跳IP 地址方式。
DCRS-7604 三层交换机的各种路由类型缺省的preference 为:
路由类型
Preference 值
直连路由
0
静态路由
1
OSPF
110
RIP
120
IBEP
200
EBGP
20
在不改变各种路由优先级值的情况下,直连路由优先级最高,依次是静态路由、EBGP、OSPF、
RIP、IBGP。
举例:
例 1.添加一条静态路由。
Switch(config)#ip route 1.1.1.0 255.255.255.0 2.1.1.1
例2.添加缺省路由。
Switch(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.1
show ip route命令:show ip route [dest <destination>] [mask <destMask>] [nextHop <nextHopValue>]
[protocol {connected | static | rip| ospf | ospf_ase | bgp | dvmrp}] [<vlan-id>] [preference
<pref>] [count]
功能:显示路由表。
参数:<destination>为目标网络地址;<destMask>为目标网络的掩码;<nextHopValue>为下
一跳IP 地址;connected 为直连路由;static 为静态路由;rip 为RIP 路由;ospf 为OSPF
路由;ospf_ase 为OSPF 引入的路由;bgp 为BGP 路由;dvmrp 为DVMRP 路由;<vlan-id>
为Vlan 标识符;<pref> 为路由优先级,取值范围为0~255;count 为显示IP 路由表项数量
信息。
命令模式:特权用户配置模式
使用指南:显示核心路由表的内容,包括:路由类型、目的网络、掩码、下一跳地址、接口
等。



中国学客联盟

[UID商城]   [抢购靓号]

高级会员

Rank: 4

UID
3553619
威望
154
贡献
0
在线时间
1 小时
注册时间
2014-6-20
金钱
39
发表于 2016-10-14 15:31:15 | 显示全部楼层
真心顶

[UID商城]   [抢购靓号]

高级会员

Rank: 4

UID
3553551
威望
153
贡献
0
在线时间
1 小时
注册时间
2014-6-18
金钱
40
发表于 2016-10-14 15:34:09 | 显示全部楼层
LZ真是人才

[UID商城]   [抢购靓号]

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640440
威望
63
贡献
0
在线时间
0 小时
注册时间
2016-10-14
金钱
12
发表于 2016-10-14 15:37:43 | 显示全部楼层
很好哦
中国学客联盟

[UID商城]   [抢购靓号]

高级会员

Rank: 4

UID
3553551
威望
153
贡献
0
在线时间
1 小时
注册时间
2014-6-18
金钱
40
发表于 2016-10-14 15:47:46 | 显示全部楼层
难得一见的好帖

[UID商城]   [抢购靓号]

中级会员

Rank: 3Rank: 3Rank: 3

UID
3640440
威望
63
贡献
0
在线时间
0 小时
注册时间
2016-10-14
金钱
12
发表于 2016-10-14 16:18:14 | 显示全部楼层
内容非常不错,谢谢楼主,我学到了
中国学客联盟
 懒得打字嘛,点击右侧快捷回复【左侧自定义内容】  【右侧自定义内容】
高级模式
B Color Image Link Quote Code Smilies

本版积分规则

快速回复 返回顶部 返回列表